Clone OpenMole from gitlab iscpif: permission denied (publickey)

(Samuel Thiriot) #1

Hello !

My problem is solved; so I’m just sharing this information here for others who would meet the same problem. And maybe it’s possible to patch the doc for that if it seems relevant to you.

I’m trying to clone the sourcecode of OpenMole; I’m following the clear steps you documented there:

Both git and lfs are installed.

At first I had to create an RSA key and add it to github so SSH can be used to connect github. Else I had an error “Permission denied (publickey)”. I then had the same error when LFS tries to fetch files from the ISC PIF gitlab:

$ git lfs clone
Clonage dans 'openmole'...
remote: Counting objects: 276394, done.
remote: Compressing objects: 100% (193/193), done.
remote: Total 276394 (delta 131), reused 378 (delta 89), pack-reused 275921
Réception d'objets: 100% (276394/276394), 132.37 MiB | 1.38 MiB/s, fait.
Résolution des deltas: 100% (108302/108302), fait.
Vérification de la connectivité... fait.
batch request: Permission denied (publickey).: exit status 255                                                                                                                                                     
error: failed to fetch some objects from ''

The solution is simple, I just had to create an account on the ISCPIF gitlab ( and add my key as done for github.

If it seems relevant, maybe we can add this requirement in the doc so people mind it ?

(Samuel Thiriot) #2

I found this doc from github clear:



That’s actually a big problem we are having with git-lfs. I think we might switch to http to make the anonymous clone work. @jopasserat do you see an alternative?

(Jonathan Passerat Palmbach) #4

Stop using gitlab?


Stop using gitlab means stop using lfs since there is not space nor bandwidth available on github. Another solution would be use only gitlab…

(Jonathan Passerat Palmbach) #6

worst case you can always drop the lfs on the git clone line, that should still work over pure http