Installation backend gargantext : coreNLP


(Laurette Chardon) #1

Re,

Toujours en poursuivant mon installation, sur coreNLP, il est dit “This dependency will not be needed
soon.” -> A priori elle est toujours nécessaire actuellement, c’est bien ça ?
La commande :
./devops/install-corenlp
fait une erreur sur wget à cause du certificat

Si on corrige en ajoutant
wget --no-check-certificate -> c’est ok

Mais ensuite la fin des logs indique :

— StanfordCoreNLPServer#main() called —
setting default constituency parser
warning: cannot find edu/stanford/nlp/models/srparser/englishSR.ser.gz
using: edu/stanford/nlp/models/lexparser/englishPCFG.ser.gz instead
to use shift reduce parser download English models jar from:
http://stanfordnlp.github.io/CoreNLP/download.html
Threads: 4
Starting server…
StanfordCoreNLPServer listening at /0:0:0:0:0:0:0:0:9000

Un process est lancé sur le port 9000 … en local ?
D’avance merci pour vos retours.

Laurette


(Alexandre Delanoe) #2

Bonjour,
le serveur CoreNLP semble bien lancé, il attend les requêtes Gargantext du backend.

Il faut donc ensuite lancer le backend.
Il existe 4 manières différentes:

  1. Debian OS (ou dérivées comme Mint ou Ubuntu)
  2. Image Open Stack
  3. Docker
  4. Nix

Pour le moment, dans le cadre du développement nous utilisons surtout les solutions 1, 2, 4 pour des raisons d’efficacité. La solution Docker a été utilisée et devrait encore être opérationnelle, je m’en assurerai pour la grande fête de la release V4. Merci de vos éventuels retours de bugs.

Alexandre